Z22YH Limp mode.

ZafiraRwp278

Member
Joined
December 15, 2018
Messages
3
Afternoon all,

Hope you can offer some advice please.

My wife has a 2007 Zafira B 2.2 Direct Automatic.

The car was serviced a couple of days ago, but did not change the plugs.
I took it for an mot yesterday, which it passed. It struggled a bit on the emissions side, but the exhaust was found to be leaking slightly.
I drove it home, but within about 5 minutes of driving, it went into limp mode, which on an automatic is not good.
The spanner light is on but no EML. No DTC’s are stored or pending. Nothing shows doing the pedal test either.
It runs quite roughly, but not all the time. It goes into limp mode almost immediately after startup.
I’ve cleaned the plugs, visibly checked the coil pack and any sensors or connections. Also cleaned the pcv and breather. Noticed the coolant was a low.
However, when I removed the dipstick with the engine running, it made a noise like a kazoo type thing. With the dipstick removed the engine still wouldn’t rev.

We’re supposed to be using it to go away next weekend so any advice would be gratefully received.

Many thanks
 

IDI AMIN

Senior Member
Joined
November 11, 2012
Messages
939
A spanner light usually means there is a fault on the electrical side.
It's possible something was unplugged when it was in the garage. Have a look around the engine bay, see if something is amiss.
You also can get the OpCom diagnostic tool on ebay for about 20 quid , well worth the investment
Best get on the forum on facebook , It's a bit more active than this web
page forum is nowadays.
 

ZafiraRwp278

Member
Joined
December 15, 2018
Messages
3
A spanner light usually means there is a fault on the electrical side.
It's possible something was unplugged when it was in the garage. Have a look around the engine bay, see if something is amiss.
You also can get the OpCom diagnostic tool on ebay for about 20 quid , well worth the investment
Best get on the forum on facebook , It's a bit more active than this web
page forum is nowadays.
Thanks for the advice......
 

KevinH

Senior Member
Joined
May 22, 2007
Messages
1,038
May be worth checking that you haven't used E10 fuel in your vehicle as the gov.uk website indicates the following:

E10 petrol is cleared for use in all Vauxhall vehicles with petrol engines, excluding:
  • Models with the 2.2 litre direct injection petrol engine, motor code: Z22YH (Vectra, Signum, Zafira) which should continue to use E5 petrol.

I believe that the use of E10 fuel with these engines can have a detrimental effect to the the high pressure fuel pump and injection system, so Super Unleaded petrol (E5) is the only fuel to use in a Z22YH.
 
Last edited:

corsaZ22se

Senior Member
Joined
December 12, 2012
Messages
2,413
When I got my first Z22 the main dealer and all the tuners recommended that it was only run on 99octane fuel. Now with E10 out there as well it is a must to run them on E5/99 octane fuel for best results in MPG's and engine life. Even more so important with the direct injection Z22YH as already said.

If you have the spanner light on there will be stored codes, You just need a better code reader like Opcom.
It will be a fault with the components that control the emissions some where? Lots to choose from like faulty MAF, coil pack, injectors, fuel pump, lambda sensors, leaking exhaust, faulty EGR etc.
 
Top Bottom