Update HTTPS Removed

Matt

Administrator
#1
I've removed HTTPS from the site, rather than renew the certificate. I've set up the correct redirects, so there should be no issues with anything on here.
 

Matt

Administrator
#3
Cool wont make a difference in the long run. If you have a good anti virus installed.
True. Also, it's just a forum, there should be nothing on here that you wouldn't want anywhere on the web anyway. HTTPS is nice to have, but does come as a marginal increase in latency due to the attitional handshaking that needs to take place.

The shop subdomain will remain behind HTTPS.
 

KevinH

Senior Member
#4
Hi Matt,

I'm getting an error with Safari on iPAD 4 (IOS 8.2):
"Safari cannot open the the page because too many redirects occurred"

Do you have any ideas why this may be ?
 

Matt

Administrator
#6
Hi Matt,

I'm getting an error with Safari on iPAD 4 (IOS 8.2):
"Safari cannot open the the page because too many redirects occurred"

Do you have any ideas why this may be ?
It will be a caching issue with the browser. I've just had it on my phone. Clear your cache, and it will be fine.
 
#9
True. Also, it's just a forum, there should be nothing on here that you wouldn't want anywhere on the web anyway. HTTPS is nice to have, but does come as a marginal increase in latency due to the attitional handshaking that needs to take place.

The shop subdomain will remain behind HTTPS.
That's true, just that I'm so used to making sure that my system is (hopefully) virus and spyware free. Some sites the wife goes on are rife with pop ups. I'm always wary as I have a home network setup with my own PC and the wife has hers. Whilst I'm probably being paranoid about it I do wonder if there's a chance of infection from our network.
 
#10
Ah rubbish I've just set up a another thread in premium members about my issues, feel free to delete it and reply in here. I can only get on on my iPhone if I google "z22se" but can't open in safari at all without error code
 

Matt

Administrator
#12
As I've already said, it's a caching issue with Safari on your phone. It's still using the https protocol, where I am now forcing httpagain. I can't do anything about it because I can't guarantee your phone has correctly cleared the cache down.
 

Matt

Administrator
#14
The issue is the browser caches the hsts setting which tells the browser to remember the site as a "secure" site. I have a setting in the htaccess file to disable this by setting the time in seconds to zero. If the browser then reread the htaccess file, httpworks. Some browsers are also caching the htaccess file, so not picking up the new value that I set.
 

Matt

Administrator
#15
I think I've finally fixed the issue with the redirect loop. The site also runs behind Cloudflare, which was offering an additional SSL connection from your computers to the server (via our own SSL). I disabled SSL with Cloudflare, but it appears something was still cached on their end. I've totally disabled Cloudflare, and the issue I was having in Firefox has gone away.
 

KevinH

Senior Member
#16
Well done Matt,

For info, here are the issues I had:

IPAD
Safari - didn't work even after clearing cache and cookies
Google Chrome - worked

PC
Internet Explorer- worked (but slow, too many overheads, who uses Microsoft anyway)
Firefox - didn't work, but switched it to private browsing and it did.

All appear to be working again now.
Thank you
 

Matt

Administrator
#17
Well done Matt,

For info, here are the issues I had:

IPAD
Safari - didn't work even after clearing cache and cookies
Google Chrome - worked

PC
Internet Explorer- worked (but slow, too many overheads, who uses Microsoft anyway)
Firefox - didn't work, but switched it to private browsing and it did.

All appear to be working again now.
Thank you
Thanks for confirming Kevin.
 
Top