Hello from Hemel Hempstead, Hertfordshire

#1
Been having a few problems with car since PO404 issue, cleaned egr, patch up hole in exhaust until I can get a new one. Was fine for about 4-5 days, roughly 20 miles done, then just started dying on me when coming to a stop or car was still trying to drive when I come to a stop (car was pulsing as if ECU didn't know what to do)
 
#2
Hello and welcome to Z22SE.
You are not that far from me as I'm near Thame.
I would guess that the EGR valve has failed. It's quite common given the age of the engine now. And as many will tell you cleaning is a temporary fix. Replacement is the answer using OEM parts (pierburg is the OEM for this part) as pattern parts generally do not work well on the Z22SE engine and usually cause as many faults as they fix.
Here is a guide to checking the P0404 fault code,
https://www.obd-codes.com/p0404
 
#3
Hi and welcome to the site. :)

As mentioned above, if cleaning doesn't resolve the issue replacement is the only real fix, unless you buy a blanking plate and cheater, but allegedly the ones available from ebay are not too reliable. This site used to sell them but demand dwindled as the cars & engines got older.

The genuine GM part # is:
12569552 - Valve,Assy.,Exhaust Gas Recirculation (appx £200 from Vauxhall dealers)

PIerburg OEM part (as mentioned above) - £129.42 from AutoVaux
https://www.autovaux.co.uk/catalogsearch/result/?q=12569552

Hope that helps. (y)
 
#5
Hello and welcome to Z22SE.
You are not that far from me as I'm near Thame.
I would guess that the EGR valve has failed. It's quite common given the age of the engine now. And as many will tell you cleaning is a temporary fix. Replacement is the answer using OEM parts (pierburg is the OEM for this part) as pattern parts generally do not work well on the Z22SE engine and usually cause as many faults as they fix.
Here is a guide to checking the P0404 fault code,
https://www.obd-codes.com/p0404
Hi, thanks for the info. I have since replaced the EGR valve, topped up the oil, topped up coolant as was a little low, checked the plugs. Once the car has warmed up, still trying to die when you come to a stop. EML has not come on again though. I am going to replace the centre and back box.
 
Top