Z22YH fuel pressure issue: feedback voltage and pressure values never change

#1
Hi, thanks for reading this post :)
Quick background: I recently bought a Zafira Z22YH Auto and I'm planning to DIY the thing into shape ... i have a 'Projects' thread here about the car
The single biggest issue I have is that the car is in limp mode cos of a fuel pressure issue.
I've been waiting to get an OpCom device to follow the recommended procedure for finding whether the fuel pressure regulator or the high pressure fuel pump is the problem.
So I finally hooked everything up today and I am getting values something that are inconsistent with any info I have seen thus far, which is why I posted a new thread, and here's what I see:
- My fuel pressure feedback value is exactly 380kpa, regardless of throttle position.
- When I follow the recommended procedure and disconnect the Fuel Pressure regulator, i get a fuel pressure feedback voltage of exactly 0.6V regardless of throttle position
- When I plug the fuel pressure regulator back in, i still get exactly 380kpa and 0.6V in all conditions... idle, full throttle and everything in between

So ... I'm very aware that this doesn't necessarily tell me whether my high-pressure fuel pump and/or fuel regulator are ok, BUT is this a clear sign that my fuel pressure sensor is dead?
 

evocarlos

Stupid Bollocks
Staff
#2
if your hp fuel pump was functional then you would be seeing 5000kpa (idle)


as per the previous info given
https://z22se.co.uk/threads/vauxhall-fault-code-p1191-5a-help-needed.24446/#post-1213156

pressure regulator
3. Pull off connector (two-core) of the fuel pressure regulator.


Measure the voltage of the fuel pressure sensor at 3000RPM (standing vehicle) with Tech2.

Is Voltage greater than 1, 2V?

Yes: Fuel pressure regulator defect, replace.

flow chart.JPG

as per the previous info given
https://z22se.co.uk/threads/vauxhall-fault-code-p1191-5a-help-needed.24446/#post-1213156

if your voltage reading of the fuel pressure sensor is above 1.2v with the regulator unplugged and 3000rpm then the fuel pressure regulator is defective if its not then its the hp pump
:)
another thing to check is theres no bent pins in the plug under the dome on the inlet (grey plug with red pull tab)
 
#3
once again, thanks for the help. your info has been invaluable to me.
and i m sorry if it seems like i didn't take your info into consideration... i definitely did and all indications are still that the pump is the problem.

But the thing that is puzzling me is that my fuel feedback pressure and voltage are staying at exactly 380kpa and 0.6V , no matter what the car does.
I see that the Fuel Pressure demand value changes according to throttle position... from 5000kpa upwards as i press on the throttle, but the feedback values remain exactly the same all the time without changing at all.
So (regardless of the issues with the regulator and pump) , I am just wondering if this is a sign that i will need to get a fuel pressure sensor since it seems odd to me that the value will not change as I change the throttle position.
 
#5
So, as advised by evocarlos, it turns out my pump is the problem... I have a cracked diaphragm. I took apart the pump yesterday (there are YouTube videos and a How-2 on the vectra-c forum that help greatly) ... and yes indeed it's a cracked diaphragm. Will order the replacements and attempt a fix.
Will update this thread as i go
 
#6
great news is that i managed to fix the pump!
Ordered the parts from eBay, took a couple of weeks to get to me, then had some delays getting to it.
Also, I couldn't get that metal ball out to open up the hole to fill the pump with oil... tried a few different things that would only have damaged the pump, so i gave up on that.
Then I saw a video on YouTube where the guy submerged the whole pump in oil and assembled it under oil.
Bloody brilliant! So I did the same and it worked! :)
Was a bit "fiddly" cos the oil I had wasn't very transparent and I had to do some of the assembly by touch rather than being able to see it clearly through the oil ...but in the end it worked, and the car idles fine now, and it's out of limp mode, and drives fine (from a fuel delivery point of view).
There are some rattles and knocks that i need to look into next, but it's so great that the car runs now!
 
Top