Check Engine in Vectra C 16V

#1
Hi all,
I will start by apologizing with the long story and English mistakes..
I have a strange problem with my Vectra C 2.2L model 2008 (face lift).
I had misfire issues and I was advised to replace the coil pack.
I bough on Ebay a cheap replacement from China which repaired the misfire problem but started to light the "check engine" light after 30 minutes drive (one trip to work and back).
I read in this forum that it is essential to use only "Delphi" coil.
Since I have the same car but earlier model Vectra C 16V 2.2L 2005 (older shape), I took the coil pack with the same GM P/N 12580357 as the original (which failed and I replaced), from Delphi. This time the car worked fine for 4 days and then the check engine light was back .
Are there any different type of versions in the original Delphi part? Diffrent firmware maybe??
Appriciate any idea and help.
Yan Benedykt
 
#5
This is related to the Camshaft Position Sensor. https://www.obd-codes.com/p0340
Check the connections and the wires first. If these seem ok then you should replace the sensor itself.
From what I read , my car doesn't have a Camshaft sensor but it is using the coil pack for that...the problem is that I used also an Original Delphi coil pack works fine on my Vectra C 2.2L model 2005, but fails on my 2008 Vectra. It all started after replacing the coil.
So know I am trying to figure if I need a specific P/N of coil pack or maybe newer date code??
 

figo126

Senior Member
#6
your engine code is a z22yh on a 2008 , and the z22yh does use a camshaft sensor and a lot more sensors than the z22se does ,, near enough same bottom end but different head and a lot more sensors,,,
 
#7
your engine code is a z22yh on a 2008 , and the z22yh does use a camshaft sensor and a lot more sensors than the z22se does ,, near enough same bottom end but different head and a lot more sensors,,,
My both cars motor engine is Z22SE 147 HP 108 KW. By the way, forgot to mention that the cars runs great with no difference before or after the light goes on.
 
Last edited:
#9
#14
Have you checked/replaced the spark plugs either?
Does the coil pack still not produce fault code in the model 2005?
How did you recognize the misfire issue? Is that completely disappeared?
 
#15
The original fault, the car was totally shaking and was not reacting smooth to the gas (I could drive slowly). So in the garage, I was recommend to replace plugs which I did, and since the fault returned I also replaced the coil pack. Then the car works great (even with cheap replacement part) beside the check engine light.
Using the ebay part in my good car (2005 model), bring to the same effect in the 2005 model, run great but lights the check engine light usually after 30-40 minutes drive.
This is when I suspected the coil pack as it was unbranded, so I switch the good original "Delphi" from the 2005 and install it on the 2008 model. It worked fine for several days but after 4 days it lights again. I added pictures of the original part I took off (first picture on the left) and the original I installed from the 2005 model (below or in the right).
Both cars runs just perfect , no power loses, just the light...
 

Attachments

Last edited:
#16
I would change back the Delphi coil pack to see whether it is still functioning without fault codes in the "good" car. Then I would still check the connections and the wires around the coil pack. Many non-persistent problems are due to loose contacts or broken wires. Have you changed the rubber plugs with the coil pack?
 
#17
I also found a thread almost identical to my issue:
https://z22se.co.uk/threads/po-341.13766/

In regard to your questions, after returning the "good" coil pack to the 2005, everything got back to normal, the car works fine and the light will not light again.
I also tried installing the "Original faulty part GM P/N 12580537" again to its original car, the model 2008 , the original fault is coming back after it heats up with serious misfiring (car shaking and runs slowly almost choking).

I also tried to mix sub parts in the original faulty part, I tried the install the original base part (black color) but replaced the rubbers and the mini computer from the Ebay part, but no success. I also got another Chinese part from Ebay (before I new it would not help)...

The car from 2005 I have from the beginning and I am sure it is a genuine part which came with the car from the factory, in regard to the model 2008, I don't know it's history but I noticed that its P/N marking was engraved , don't know if that means anything but maybe its newer Firmware version?

Meanwhile I will order from Ebay another used Delphi original Coil Pack to see if it helps.
Many thanks for all your help guys!
 
#18
Hi,
I would appreciate if someone can suggest another directions for this investigation:
Updates from last post:
1. I bought new "Delphi" coil from Ebay, the Check Engine still lights (On the Vectra C 2.2L Z22SE face lift).
2. I replaced the last bought Coil and installed it with my second Vectra C 2.2L Z22SE (model 2005) , and no Check engine in the 2005
3. The Original from factory coil (Took from 2005 model) was installed on the 2008 model and Check Engine lights.

Now I used a OBDII tool (general on - ELM) and connected it to APP , it presented failure P0420 "Catalyst system efficiency below threshold (bank 1)"
Is it the Catalyst converter I need to replace ?
If I remember, and since the car was running smoothly before I started the original failure of misfiring, and while I had misfiring I drive the car for few KM, maybe by driving the car with bad coil I damaged the catalyst converter ?? :whistle:
 
#19
not 100% but i believe the Vectra C z22se has a manicat, older z22se's have a precat and main cat. the pre cats fail and cause running problems like you have. not sure if yours will have same faults if cat has failed/become blocked? both of these can happen as a result of poor running due to another issue such as poor fueling/timing error's, oil burning, miss fires.
 
#20
I ran some tests with OBDII and took some snapshots from both Vectra's I have. The car with the P0420 fault has more unstable Voltage in the sensor O2S2. Trying to look on Youtube, I found a video which suggests for vacum problem or bad gasket which allow too much air to get in the system.
After viewing this, I remembered that one time after replacing the air filter and also disconnecting and re-assembling the air filter housing, the check engine light went off for few days... so I do believe that something around the elements which control the air getting in the system could cause this fault. Also attached snap shots from OBD tool of oxygen sensors (ran the test in idle and 3000 rpm) .
Thanks.
 

Attachments

Top